[R-pkg-devel] Advice on elegant way to alias function name

Hadley Wickham h@w|ckh@m @end|ng |rom gm@||@com
Thu Sep 1 17:29:33 CEST 2022


On Thu, Sep 1, 2022 at 9:48 AM J C Nash <profjcnash using gmail.com> wrote:
>
> Hi,
>
> I've a package where it has been suggested that one of the functions -- call
> it "myfn()" -- should be called something else, say "thefn()". Of course, I'll
> need to keep the old name around for a while.
>
> Web search has suggested simple assignment of
>
>      thefn <- myfn
>
> but I cannot seem to get this to work with R CMD check when I put this in a .R
> file in the code and put alias and usage stanzas in documentation. I get alias
> and missing argument type errors. I've tried a number of variations on this theme
> without appreciable success.
>
> A workaround is to copy the entire function with Roxygen2 documentation and
> name change, but this seems inelegant.

You'll also need to add a couple of roxygen tags:

#' @export
#' @rdname myfn
thefn <- myfn

Hadley

-- 
http://hadley.nz



More information about the R-package-devel mailing list