[R-pkg-devel] Help with reproducing (and solving) clang-UBSAN and Solaris installation errors

SN248 @n248 @ending from cornell@edu
Sat Jul 7 06:53:31 CEST 2018

Dear all

I recently submitted an R package to CRAN which was accepted. However, the
package is failing additional tests, i.e., it fails to install on Solaris
and also produces a clang-UBSAN issue. These can be seen here


I tried to reproduce the installation error for Solaris and clang-UBSAN
issue using rhub (R package). However, in both cases, I don't see any error
reported by rhub.

Solaris installation went fine (Oracle Solaris 10, x86, 32 bit, R-patched
(experimental)). See the report below:



No errors were reported when I run 'check_with_sanitizers()' command (I
assume that is the right command to generate clang-UBSAN errors, though the
Platform information is - Debian Linux, R-devel, GCC ASAN/UBSAN). See the
report of the test below:


I am not sure how to proceed with debugging those errors as I am not able
to reproduce them. Is there any way to test installation on Solaris (I
don't have access to one, unfortunately) and reproduce clang-UBSAN issue.

The clang-UBSAN issue _may_ be related to Rcpp::XPtr and _may_ remain
unresolved (based on the thread in Rcpp-devel forum earlier (I could have
mis-interpreted the whole discussion there) -

Any help in how to reproduce these issues will be highly appreciated.

On a separate note - in case these issues remain unresolved, is the package
doomed to go to CRAN archives then? The package installation and running
examples went without error/warning/note on all the platforms in rhub.


	[[alternative HTML version deleted]]

More information about the R-package-devel mailing list