[R] Problems with installing R packages from source and running C++ in R, even on fresh R installation

Christophe Bousquet chr_bou@quet @end|ng |rom protonm@||@com
Fri Sep 1 11:05:45 CEST 2023

> Is there a "C:\Program Files\R\R-4.3.1\bin\x64\Rterm.exe"? If you
> launch it, does it present an R command line?

Yes, this file exists and when I launch it, a new functionally-working R terminal window pops up.

> I'm suspecting that Rcmd.exe somehow messes up when it tries to locate
> Rterm.exe to launch it. Here's one way to see what happens:
> 1. Download Sysinternals Process Monitor, a free monitoring utility,
> from the Microsoft website and launch it (no installation needed):
> https://learn.microsoft.com/en-us/sysinternals/downloads/procmon
> 2. Set up the filter so that so that entries are included
> - Process name is "Rcmd.exe"
> - Operation is "Process Create"
> 3. Run tools::Rcmd('SHLIB --help') (or any other Rcmd invocation that
> fails to produce any output for you)
> 4. You should get one event of Rcmd.exe trying to launch cmd.exe with a
> long command line. What is the command line?

For 2., I also added the Process name "Rterm.exe"
Here are the outputs from Process Monitor for each situation.
In the first situation, I run the command tools::Rcmd('SHLIB --help') from within R (launched by clicking on the R icon). I get:
Process Name: Rcmd.exe
PID: 8204
Path: C:\WINDOWS\System32\Conhost.exe
Detail: PID: 4028, Command line: \??\C:\WINDOWS\system32\conhost.exe 0xffffffff -ForceV1

In the second situation, I run the command tools::Rcmd('SHLIB --help') from the R terminal (launched by clicking on Rterm.exe). I get:
Process Name: Rterm.exe
PID: 14596
Path: C:\PROGRA~1\R\R-43~1.1\bin\x64\Rcmd.exe
Detail: PID: 6820, Command line: C:\PROGRA~1\R\R-43~1.1\bin\x64\Rcmd.exe SHLIB --help

Best regards,

More information about the R-help mailing list