[R] Huge differences in Ram Consumption with different versions of R on the same scripts

Robert Knight bobby@kn|ght @end|ng |rom gm@||@com
Mon May 8 03:40:09 CEST 2023

Hello R Help,

I have some R vignettes that run fpp2 time series regressions.  I have run
these for a long time using R and a 12 core computer system.  I ran each
core using Linux to run a vignette on that core, so that all 12 could work
concurrently.  With 48GB of ram, the ram never filled up. I ran these
regressions for hours, one data set right after the other on each core.
Recently, I switched to Oracle Linux 8 and R 4.2 Now, with the same
scripts, and the same data, the ram fills up and R reserves 4.2GB per
instance in some cases.  This results in all the ram being consumed and the
swap space on the system activating constantly so that the performance is
abysmal. It begins using 12Gb of swap space in addition to the ram
consumed.  It bogs the system so bad that one can't even establish new
terminal sessions.

Is there a way to specify a maximum ram allowance in an R vignette?  If
that’s not possible, what resources can you recommend to help identify the
reason for the change in memory use?  Why would a different version of
R/Linux use 2GB per instance, while another uses 4.4GB? What kind of
troubleshooting or programming techniques should I research for this kind
of concern?
Robert Knight

	[[alternative HTML version deleted]]

More information about the R-help mailing list