[R] GSL update fails configuration

Ivan Krylov kry|ov@r00t @end|ng |rom gm@||@com
Thu May 19 17:04:51 CEST 2022

В Thu, 19 May 2022 07:38:45 -0700 (PDT)
Rich Shepard <rshepard using appl-ecosys.com> пишет:

> Since GSL-2.1 is found on line 2, why is there the error on line 11
> that gsl >= 1.16 is needed and not found?

In the current CRAN version of the package, the stated dependencies are
in wild disagreement with each other:

DESCRIPTION says that GSL >= 2.1 is required, ./configure error message
asks for >= 1.16, but the actual test is for GSL >= 2.5:

(Well, it's intended to test for >=2.5, but seems to test for any minor
version of 5 and above instead.)

I'm not sure which GSL features the package actually makes use of. You
can either try patching ./configure to actually check for GSL >= 2.1
and rebuilding the package (at which point something else may fail) or
upgrade GSL to >= 2.5.

Best regards,

More information about the R-help mailing list