[R] Problem Compiling v-4.x.x

Stephen P. Molnar @@mo|n@r @end|ng |rom @bcg|ob@|@net
Tue Nov 9 15:22:41 CET 2021

On 11/09/2021 04:52 AM, Duncan Murdoch wrote:
> On 08/11/2021 3:56 p.m., Stephen P. Molnar wrote:
>> On 11/08/2021 03:15 PM, Duncan Murdoch wrote:
>>> On 08/11/2021 2:57 p.m., Stephen P. Molnar wrote:
>>>> I have uptodate Debian Buster on my Linux platform and have been
>>>> compiling R distros for quite some time, usually with success.
>>>> This time I have encountered the same error in my attempts to compile
>>>> v-4..1.2 and then, when that failed, I had the same error with 
>>>> v-4.1.0.
>>>> The error in both cases was:
>>>> /home/comp/Downloads/R Packages/R-4.1.0/R-4.1.0/etc/Makeconf:10:
>>>> Packages/R-4.1.0/R-4.1.0/share/make/vars.mk: No such file or 
>>>> directory.
>>>> I don't have the faintest idea as to what is going on, and, even 
>>>> worse,
>>>> I don't know how to fix it.
>>>> Help will be greatly appreciated.
>>> I think you'll need to describe what you did that led to this error.
>>> Duncan Murdoch
>> True, very true. Sorroy for the omission.
>> ./configure
>> /make
> Hopefully Ivan's suggestion solves your problem. One thing I'd 
> suggest: building in a different dir than the source.  All you need is 
> to put the source in some dir (e.g. "src"), switch to an empty dir, 
> and run src/configure from there, followed by make. This makes for a 
> cleaner separation of source and products.
> Duncan Murdoch
That was certainly a red-faced forehead slapper!!

I should have known better. I changed the name of ~/Downloads/R Packages 
to ~/Downloads/R_Packages and the problem went away.

Many thanks to you all for your patience and solutions.

Stephen P. Molnar, Ph.D.
614.312.7528 (c)
Skype:  smolnar1

More information about the R-help mailing list