[R] Warning msg after reinstall?

Brian Lunergan ||809 @end|ng |rom nc|@c@
Mon Nov 8 03:26:45 CET 2021

On 2021-11-07 5:17 p.m., Jeff Newmiller wrote:
> The topic here is R language, not operating system surgery. You probably shouldn't hold your breath for a solution to this here.
> That said, compiling and running without installing for access by the whole system is always an option if you can fix the support libraries.
> On November 7, 2021 2:07:20 PM PST, Brian Lunergan <ff809 using ncf.ca> wrote:
>> Evening gents:
>> First to quickly try and set the scene.
>> I run R on Linux Mint 19.3. I had version 3.5 installed, but wanted to
>> try and upgrade to 4.1. So... I deleted all R stuff I could find, setup
>> the software sources file, and tried to install. Didn't work. I suppose
>> it needs a more recent edition of Mint. Backpedalled as best I could.
>> Now 3.5 was uncooperative. Finally found some notes describing how to
>> install 3.6. That worked. So now I again have a functioning copy of R,
>> with a current edition of Rstudio as my principle access tool. Adding
>> pkgs through the software manager doesn't seem to be work, but as long
>> as I fire it up using the sudo command I can add them through Rstudio.
>> The puzzle comes at the end of an install round. It seems I may have
>> taken out something I shouldn't have as I get the following warning.
>> Warning messages:
>> 1: In readLines(file, skipNul = TRUE) :
>>  cannot open compressed file
>> '/usr/lib/R/site-library/labelled/DESCRIPTION', probable reason 'No such
>> file or directory'
>> 2: In readLines(file, skipNul = TRUE) :
>>  cannot open compressed file
>> '/usr/lib/R/site-library/TH.data/DESCRIPTION', probable reason 'No such
>> file or directory'
>> I'm not really sure. I assume I got sloppy withe deletions. I ask for
>> assistance to solve this. What does it mean? What can I do to correct
>> the error? Thanks in advance.

Point taken Jeff, IF it were a Linux msg. But it's not, having appeared
within an active R session following the install of some pkgs, so I
thought here was a logical place to start. The directory is present but
apparently the file is not. No doubt I approached things in a
disorganized way and deleted it when I should have left it alone. So
perhaps you or one of the other group members could suggest how to
replace what R is seeking or, if not here, what R group I might approach
to find an answer for this R problem,

Brian Lunergan
Pavillon Marionville
Russell, Ontario

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 665 bytes
Desc: OpenPGP digital signature
URL: <https://stat.ethz.ch/pipermail/r-help/attachments/20211107/3dd1c4ee/attachment.sig>

More information about the R-help mailing list