[R] Installing an Archived Package

Evguenia Ignatova evg@|gn@tov@ @end|ng |rom gm@||@com
Wed May 16 20:15:35 CEST 2018

Hello again,

I did not expect the browser to automatically extract, so I changed the Safari setting and it downloaded as a “gz” file.

It is clear now that R is finding the package but I get a different error as follows:

> install.packages("polycor_0.7-8.tar.gz", repos=NULL, type="source")
ERROR: dependency ‘mvtnorm’ is not available for package ‘polycor’
* removing ‘/Library/Frameworks/R.framework/Versions/3.2/Resources/library/polycor’
Warning message:
In install.packages("polycor_0.7-8.tar.gz", repos = NULL, type = "source") :
  installation of package ‘polycor_0.7-8.tar.gz’ had non-zero exit status

I get the same error when I try Rui’s way of accessing the file.

Suggestions online are along the lines of installing the dependencies separately, but I am not sure how to go about separating the file into its dependencies?

Thank you so much!


> On May 16, 2018, at 1:58 PM, Richard M. Heiberger <rmh using temple.edu> wrote:
> You can tell Macintosh not to automatically unpack tar.gz files.
> https://apple.stackexchange.com/questions/961/how-to-stop-safari-from-unzipping-files-after-download <https://apple.stackexchange.com/questions/961/how-to-stop-safari-from-unzipping-files-after-download>
> On Wed, May 16, 2018 at 11:24 AM, Evguenia Ignatova
> <evg.ignatova using gmail.com <mailto:evg.ignatova using gmail.com>> wrote:
>> Hello,
>> I am having difficulty installing the most recent compatible version of the “polycor" package (0.7-8), for R 3.2.1 on my Mac. Here is the package source page: https://cran.r-project.org/src/contrib/Archive/polycor/ <https://cran.r-project.org/src/contrib/Archive/polycor/> <https://cran.r-project.org/src/contrib/Archive/polycor/ <https://cran.r-project.org/src/contrib/Archive/polycor/>>.
>> This version of R is necessary for the R Essentials for the IBM Statistical Package for Social Sciences (SPSS) extension. I found this thread on the problem (http://r.789695.n4.nabble.com/Installing-polycor-package-td4726101.html <http://r.789695.n4.nabble.com/Installing-polycor-package-td4726101.html> <http://r.789695.n4.nabble.com/Installing-polycor-package-td4726101.html <http://r.789695.n4.nabble.com/Installing-polycor-package-td4726101.html>>) but it does not offer much help as my SPSS version will not recognize the most recent versions of R.
>> The polycor package is not available in the repository of R 3.2.1. Here is the code I tried to install the package from the archive and the errors I received:
>>> install.packages("/polycor_0.7-8.tar", repos=NULL, type="source")
>> Warning: invalid package ‘/polycor_0.7-8.tar’
>> Error: ERROR: no packages specified
>> Warning message:
>> In install.packages("/polycor_0.7-8.tar", repos = NULL, type = "source") :
>>  installation of package ‘/polycor_0.7-8.tar’ had non-zero exit status
>>> install.packages("https://cran.r-project.org/src/contrib/Archive/polycor/polycor_0.7-8.tar.gz", repos=NULL, type="source")
>> Error in download.file(p, destfile, method, mode = "wb", ...) :
>>  unsupported URL scheme
>> Any ideas for other alternatives would be greatly appreciated. Thank you for your time!
>> Best,
>> Evguenia
>>        [[alternative HTML version deleted]]
>> ______________________________________________
>> R-help using r-project.org <mailto:R-help using r-project.org> mailing list -- To UNSUBSCRIBE and more, see
>> https://stat.ethz.ch/mailman/listinfo/r-help <https://stat.ethz.ch/mailman/listinfo/r-help>
>> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html <http://www.r-project.org/posting-guide.html>
>> and provide commented, minimal, self-contained, reproducible code.

	[[alternative HTML version deleted]]

More information about the R-help mailing list