[R] Updating Rcpp package when it is claimed by dplyr

Patrick Connolly p_connolly at slingshot.co.nz
Fri Feb 2 08:00:01 CET 2018

When i  tried to install the hunspell package, I got this error message:

Error: package ‘Rcpp’ 0.12.3 was found, but >= 0.12.12 is required by ‘hunspell’

So I set about installing a new version of Rcpp but I get this message:

Error in unloadNamespace(pkg_name) : 
  namespace ‘Rcpp’ is imported by ‘dplyr’ so cannot be unloaded

How does one get around that?  I tried installing Rcpp in a vanilla
session but the result was the same.


> sessionInfo()
R version 3.4.3 (2017-11-30)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.5 LTS

Matrix products: default
BLAS: /home/pat/local/R-3.4.3/lib/libRblas.so
LAPACK: /home/pat/local/R-3.4.3/lib/libRlapack.so

 [1] LC_CTYPE=en_NZ.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_NZ.UTF-8        LC_COLLATE=en_NZ.UTF-8    
 [7] LC_PAPER=en_NZ.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] utils     stats     grDevices graphics  methods   base     

other attached packages:
[1] lattice_0.20-35

loaded via a namespace (and not attached):
 [1] compiler_3.4.3 magrittr_1.5   R6_2.1.2       assertthat_0.1 parallel_3.4.3
 [6] tools_3.4.3    DBI_0.3.1      dplyr_0.4.3    Rcpp_0.12.3    grid_3.4.3    

   ___    Patrick Connolly   
 {~._.~}                   Great minds discuss ideas    
 _( Y )_  	         Average minds discuss events 
(:_~*~_:)                  Small minds discuss people  
 (_)-(_)  	                      ..... Eleanor Roosevelt

More information about the R-help mailing list