[R] R_LIBS_USER not in libPaths

Michael Dewey lists at dewey.myzen.co.uk
Sat Sep 16 17:35:56 CEST 2017

Dear Rene

I am not sure I understand your problem so this may be completely uselss 
but when I am going to run R from the command line I first of all run a 
little batch file.

set R_HOME=C:\Users\Michael\Documents\bin\R\R-3.4.1
set R_PATH=%R_HOME%\bin\x64

Someone (forgotten who, sorry) posted this years ago on this site.


On 16/09/2017 14:16, Rene J Suarez-Soto wrote:
> I have a computer where R_LIBS_USER is not found in libPaths. This is for
> Windows (x64). I ran R from the command line, RGui and RStudio and I get
> the same results. I also ran R --vanilla and I still get the discrepancy.
> The only thing I found interesting was that I also ran SET from the command
> line and the "R related variables" (e.g.,  R_HOME; R_LIBS_USER) are not
> there. Therefore these variables are being set when I start R. I have not
> been able to track where does R obtain the value for these.
> Aside from looking at
> http://stat.ethz.ch/R-manual/R-patched/library/base/html/Startup.html I am
> not sure I have much more information that I have found useful.
> Thanks
> R
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
> ---
> This email has been checked for viruses by AVG.
> http://www.avg.com


More information about the R-help mailing list