[R] (no subject)
murdoch.duncan at gmail.com
Wed Sep 13 14:57:36 CEST 2017
On 13/09/2017 5:23 AM, Brayford, David wrote:
> When I try to install gsl in R I get the error Need GSL version >= 1.12 . However, I have version 2.3 of gsl installed on the system, which is picked up earlier in the configure process (see below). Is it possible for someone to fix this error in the configure script?
> checking for gsl-config... /lrz/sys/libraries/gsl/2.3/bin/gsl-config
> checking if GSL version >= 1.12... checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> configure: error: Need GSL version >= 1.12
> ERROR: configuration failed for package �gsl�
As Berend said, this should be talked about with the maintainer. It
would be helpful if you could show more detail of the test that failed.
For example, what does
/lrz/sys/libraries/gsl/2.3/bin/gsl-config --version --cflags
print? For me, the second line from gsl-config is
and I can see using
that the macros are defined as
#define GSL_VERSION "1.16"
#define GSL_MAJOR_VERSION 1
#define GSL_MINOR_VERSION 16
Presumably you'll get something else...
More information about the R-help