[R] [Rd] italic font on cairo devices in R 3.4

Ilia Kats ilia-kats at gmx.net
Fri Jul 7 19:08:52 CEST 2017

Interesting. I did not have the package installed, but I did at some 
point extract Helvetica from some MacOSX font files and R was using that 
just fine until 3.3. This is how the plot looks in 3.4 (still using 
Helvetica): https://ptpb.pw/HikX.pdf . After removing Helvetica, 
installing the ttf-mscorefonts-installer package, and running fc-cache 
--force  the plot looks like this: https://ptpb.pw/CM8A.pdf

Also note that the standard pdf device works fine: 
https://ptpb.pw/3Ml1.pdf , it's just the cairo devices (both pdf and 
svg) that have the issue. Unfortunately I need to use cairo_pdf due to 
unicode characters in axis labels.

Cheers, Ilia

-------- Original Message --------
Subject: Re: [Rd] italic font on cairo devices in R 3.4
Date: 2017-07-07 18:17:34 +0200
From: frederik
To: Ilia Kats
CC: r-devel, r-help
> Hi Ilia,
> I'm running Arch Linux, R 3.4.0.
> Here's my test.pdf from your minimal example: https://ptpb.pw/HxsA.pdf
> It doesn't look pixelated to me...
> Here's a post that I wrote when I solved my last font problem in R,
> almost 2 years ago:
> https://stackoverflow.com/a/40940331/5087283
> I had to install some Microsoft font packages, which is sad, because
> there are some perfectly good free fonts that R could be using
> instead. It could be considered a bug that R requires Microsoft fonts,
> at least by default. However, does this even fix your problem? I.e. if
> you install the corresponding Debian Microsoft font packages, does the
> text appear anti-aliased?
> Frederick
> On Fri, Jul 07, 2017 at 10:30:46AM +0200, Ilia Kats wrote:
>> [cross-post from R-help]
>> Hi all,
>> I have the following problem: Since R 3.4.0, italic fonts rendered on Cairo
>> devices appear pixelated. Here's a minimal example:
>> cairo_pdf('test.pdf')
>> plot(1:10, ylab=expression(italic(test)))
>> dev.off()
>> The same problem occurs with bolditalic, but not bold. I am using Debian
>> Stretch. Several friends tried the same on their machines, another Debian
>> machine has the same problem. On MacOSX the output was not pixelated, but it
>> wasn't italic either. Ubuntu 16.04.2 xenial works fine. My impression is
>> that R somehow can't find the proper font to use and falls back to something
>> weird. Ideas?
>> Note that I'm not subscribed to the list, so please CC me in replies.
>> Cheers, Ilia
>> ______________________________________________
>> R-devel at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-devel

The first is to ensure your partner understands that nature has root
privileges - nature doesn't have to make sense.
-- Telsa Gwynne

More information about the R-help mailing list