[R] tcltk makes R crash under Mavericks

Berend Hasselman bhh at xs4all.nl
Mon Jan 13 19:51:00 CET 2014

On 13-01-2014, at 19:30, Claudia Tebaldi <claudia.tebaldi at gmail.com> wrote:

> Hello
> I was just forced to upgrade my OS X to Mavericks. Everything seemed to be
> OK, R still worked seemingly fine within emacs (am using the latest
> version, R 3.0.2, and the latest version of ESS, with Emacs 24.3.1) until I
> tried loading the library extRemes. Apparently the call within that library
> to load tcltk was the culprit. In fact R crashes simply by trying to load
> the latter (without trying loading extRemes). I tried reinstalling
> everything (R and the packages, and the tools' tcltk package -- even if I
> think it should be bundled with R by default).

It is bundled with R 3.0.0 and higher. See the NOTE in bold on http://cran.r-project.org/bin/macosx/tools
Just install R and you will have tcl/tk 8.6.0.


> R keeps crashing with a
> simple "R process terminated" message.
> Everything worked just swimmingly under Snow Leopard. Sigh.
> Can anybody please help?
> Thank you
> Claudia
> Claudia Tebaldi
> Project Scientist,
> and Science Fellow
> Climate Central
> (303) 497 1710 w
> (303) 775 5365 c
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list