[R] cannot load rcmdr

John Fox jfox at mcmaster.ca
Wed Apr 23 23:21:42 CEST 2014

Dear Mickael,

assignInMyNamespace() is a standard R function, in the tools package, and so with up-to-date versions of R and the Rcmdr package, you should not be experiencing this problem. Can you provide some more information, such as the operating system you're using, the R version (current is 3.1.0), and the version of the Rcmdr package (current is 2.0-4)? If you're not using the latest versions, I'd start by updating.

I hope this helps,

On Wed, 23 Apr 2014 13:27:14 +0000
 Mickael Vieira Da Silva <2130756 at my.ipleiria.pt> wrote:
> After install the package RCMDR, I try to load it and it always apears the same error message:
> Error : .onAttach failed in attachNamespace() for 'Rcmdr', details:
>   call: Commander()
>   error: could not find function "assignInMyNamespace"
> Error: package/namespace load failed for 'Rcmdr'
> I have the R version 2.14.2
> the same error apears with a newest version
> How can I solve this problem?
> best regards

John Fox, Professor
McMaster University
Hamilton, Ontario, Canada

More information about the R-help mailing list