[R] Any solution to have RnetCDF, ncdf or ncdf4 in R 3.1 ?

Marc Girondot marc_grt at yahoo.fr
Mon Apr 7 01:21:59 CEST 2014

Le 06/04/2014 16:47, David W. Pierce a écrit :
> Hi Marc,
> those packages are just interfaces to the netcdf library that must 
> already exist on your machine. Try installing the netcdf library 
> first, and then installing the R package.
> You will need the development version of the netcdf library installed 
> in order to compile the R packages. Hopefully the exact package name 
> will be obvious in the package manager on your system.
Thanks a lot for these infos.
Here are the last news for my problem of installation package in 3.1:

I have installed macport and then I have tried to install development 
version of netcdf library:
sudo port install netcdf-devel
Error: Port netcdf-devel not found

The netcdf library is available in macport but not the development one.

In the meantime, I have tried to install ncdf and ncdf4 package after 
downloading the MacosX binary versions at:

I have installed both using the install_local() function of the package 
Both install and run correctly.

The same procedure applied to RNetCDF 
(http://cran.r-project.org/web/packages/RNetCDF/index.html) has produced 
an error during installation.

I have installed other packages in 3.1, or directly using 
install.packages() or loading the MacosX binary and using 
install_local(). I have still a problem with rgdal 
(http://cran.r-project.org/web/packages/rgdal/index.html). Probably 
again it is a problem of library (gdal) that is not present. I will wait 
that binary library is available in CRAN.


More information about the R-help mailing list