[R] "Error: cannot allocate vector of size 1.9 Gb" when loading xtable help

Dan Keshet dkesh at qcue.com
Sat Jun 15 01:02:33 CEST 2013

I am using xtable version 1.7-1 built for R 3.0.1 on:

R version 3.0.1 (2013-05-16)
Platform: i686-pc-linux-gnu (32-bit)

Sometimes, not every time, when I load xtable or attempt to load the
help, I get an error such as this "Error: cannot allocate vector of
size 1.9 Gb" (Stacktrace from recover() below).

Other times, when loading packages that depend on xtable, I get an
error such as this:

Loading required namespace: xtable
Error in assign(identifier, list(name, description, identifier, help,  :
  lazy-load database 'P' is corrupt

I have attempted to reinstall the package using
install.packages("xtable", type="source"), but the error persists (and
the xtable.rdb file is identical).

I have also tried this on macs and gotten the same error.

Thank you for any help.

> ?xtable
Error: cannot allocate vector of size 1.9 Gb

Enter a frame number, or 0 to exit

1: print("/usr/local/analytics/rlibs/xtable/help/xtable")
2: print.help_files_with_topic("/usr/local/analytics/rlibs/xtable/help/xtable"
3: tools::Rd2txt(.getHelpFile(file), out = tempfile("Rtxt"), package = pkgname
4: prepare_Rd(Rd, defines = defines, stages = stages, fragment = fragment, ...
5: .getHelpFile(file)
6: tools:::fetchRdDB(RdDB, basename(file))
7: lazyLoadDBexec(filebase, fun)
8: fun(environment())
9: fetch(key)

More information about the R-help mailing list