[R] mgcv stopped working mid-session

Bryan Althouse balthouse at wisc.edu
Sun Feb 26 06:36:10 CET 2012

I am working in R 2.13.2 GUI 1.42 Leopard build 32-bit (5910) on a MacBook Pro. I am working with a data frame of 22 columns and approximately 7,100 rows. I have been using the package scatter3d routinely to work similar data sets. However, when I tried to use scatter3d to work with this new data set I get the following message...

Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so':
  dlopen(/Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so, 6): Library not loaded: @rpath/R.framework/Versions/2.13/Resources/lib/libRlapack.dylib
  Referenced from: /Library/Frameworks/R.framework/Versions/2.13/Resources/library/mgcv/libs/i386/mgcv.so
  Reason: image not found
Error: package/namespace load failed for 'mgcv'

I don't understand why this has happened since I was using the scatter3d package just fine, Then when I created a new data frame a few minutes later (that is literally the only change I have made) scatter3d just stopped working and I got the above error message. When I try to load mgcv on its own, it won't load and I get the same message. I tried re-instaling mgcv and loading that in, but that did not work either. 

I have gotten this message with other packages that have worked fine in the past such as VGAM. 

Any insight you may have into the matter would be greatly appreciated.

Bryan Althouse
Graduate Student
UW-Madison Center for Limnology

More information about the R-help mailing list