[R] Matrix multiplication gives different results some of the times (NaN)

Rolf Turner rolf.turner at xtra.co.nz
Tue Sep 13 11:01:13 CEST 2011

I tried your example code on my laptop running Ubuntu Linux,
and of course it ran --- just as it should (*has* to!) without any
problem; no errors thrown.

This sort of thing should not/does not/cannot happen under
``normal circumstances''.  There has to be something wrong
somewhere in your setup.  Either your hardware or your software
is flaky in some way.

I.e. it is not an "R problem".

How you track down the flakiness is unfortunately way beyond me.


         Rolf Turner

On 13/09/11 20:07, Xavier Fernández i Marín wrote:
> Joshua Wiley vas escriure el dia dt, 13 set 2011:
>> I cannot replicate this on, even with 1 milllion reps on:
>> R version 2.13.1 (2011-07-08)
>> Platform: i386-pc-mingw32/i386 (32-bit)
>> or
>> R Under development (unstable) (2011-08-13 r56733)
>> Platform: x86_64-pc-mingw32/x64 (64-bit)
>> Perhaps it is OS dependent (I am away from my linux box at the moment)?
> Yes, this was my first guess, since I compiled R with aggressive options
> (-Ofast) in GCC 4.6. But then I tried also with the recommended -O2, and
> recompiled blas and lapack as well, just in case it was something related
> to some of their routines.
> But I am still having problems.
> Thank you,

More information about the R-help mailing list