[R] install "multtest" and "preprocessCore" packages in Bioconductor library

R. Michael Weylandt michael.weylandt at gmail.com
Wed Nov 30 19:13:25 CET 2011

My apologies: the posting guide doesn't actually suggest updating to
the most recent stable version -- though perhaps it would be a good
addition to the "before posting" section -- but I still think that's
the necessary fix to your problem.


On Wed, Nov 30, 2011 at 1:08 PM, R. Michael Weylandt
<michael.weylandt at gmail.com> wrote:
> As the posting guide strongly suggests, I think the first step is to
> update to R 2.14: there have been changes in package design and I'm
> not sure back-compatibility will run that far. Doing so should let you
> download fresh binaries straight from BioC.
> I'm not sure why you would get compilation errors if you are just
> installing a binary -- are you sure you're doing it right? What are
> your commands?
> I think follow-up should be directed to the dedicated BioConductor
> list, but I assume they will tell you the same thing: 1) Update R and
> try to install prepackaged libraries; 2) install local copies of the
> binaries; 3) only compile from source if needed (you probably don't
> have a fortran compiler which seems to be part of the problem)
> Michael
> On Wed, Nov 30, 2011 at 12:57 PM, UyenThao Nguyen <unguyen at tethysbio.com> wrote:
>> Hi All,
>> I've tried to install these "multtest" and "preprocessCore" packages in Mac, but kept getting error messages. I tried to load the packages using 2 ways:
>> 1. Installed from BioConductor (sources)
>> 2. And installed from BioConductor (binaries)
>> Both ways, I got these error messages:
>> For preprocessCore:
>> ld: warning: directory '/usr/local/lib' following -L not found
>> ld: library not found for -lgfortran
>> collect2: ld returned 1 exit status
>> make: *** [preprocessCore.so] Error 1
>> ERROR: compilation failed for package ‘preprocessCore’
>> * removing ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/library/preprocessCore’
>> * restoring previous ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/library/preprocessCore’
>> For multtest:
>> ld: warning: directory '/usr/local/lib' following -L not found
>> ** arch - x86_64
>> Looks like the error got to do with L drive, which I don't know how to fix it. Please help. Any suggestions will be greatly appreciated.
>> Thank you very much,
>> Nguyen
>> ______________________________________________
>> R-help at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list