[R] Problem with R CMD check and the inconsolata font business.

Brian Diggs diggsb at ohsu.edu
Thu Nov 3 23:30:30 CET 2011

On 11/3/2011 2:29 PM, Rolf Turner wrote:
> On 03/11/11 20:37, Rolf Turner wrote:
>> I have just installed R version 2.14.0 and tried to re-build and
>> re-check some
>> of the packages that I maintain.
>> I'm getting a warning (in the process of running R CMD check on my
>> "deldir"
>> package):
>>> * checking PDF version of manual ... WARNING
>>> LaTeX errors when creating PDF version.
>>> This typically indicates Rd problems.
>>> LaTeX errors found:
>>> ! Font T1/fi4/m/n/10=ec-inconsolata at 10.0pt not loadable: Metric
>>> (TFM) file n
>>> ot found.
>>> <to be read again>
> <SNIP>
> I received two replies off-line and one that was sent to the list. The
> gist of the
> off-line replies was ``you need to install some fonts'', and (unusually,
> and very
> kindly! :-) ) the responders told me *how* to do so.

<SNIP (descriptions of how to install on various Linux distributions)>

> The third message (which *was* posted to the list) was from Brian Diggs,
> who said that he was having a related problem:
>> The error on R CMD check I get is:
>> * checking PDF version of manual ... WARNING
>> LaTeX errors when creating PDF version.
>> This typically indicates Rd problems.
>> LaTeX errors found:
>> !pdfTeX error: pdflatex.EXE (file ec-inconsolata): Font ec-inconsolata
>> at 540 n
>> ot found
>> ==> Fatal error occurred, no output PDF file produced!
> I think this is the same as/similar to the problem I had before I installed
> the inconsolata (LaTeX) package from CTAN. Since Brian does Windoze I
> cannot advise as to how to install the package on his system, but I presume
> it is not too difficult --- once you know how! :-)

I thought that making sure the proper latex packages were installed 
would be sufficient, but apparently not.  I found the actual font at 
http://www.levien.com/type/myfonts/Inconsolata.otf, downloaded it, and 
installed it.  It shows up in my list of fonts available (as Inconsolata 
Medium) via the control panel.  However, I still get the same error from 
R CMD check.  I tried rebuilding the TeX filename database, but that 
didn't help.  I've searched my drive for any mention of inconsolata, and 
the hits are:

./Program Files (x86)/MiKTeX 2.9/doc/fonts/inconsolata
./Program Files (x86)/MiKTeX 2.9/doc/fonts/inconsolata/inconsolata.pdf
./Program Files (x86)/MiKTeX 2.9/fonts/enc/dvips/inconsolata
./Program Files (x86)/MiKTeX 2.9/fonts/map/dvips/inconsolata
./Program Files (x86)/MiKTeX 2.9/fonts/opentype/public/inconsolata
./Program Files (x86)/MiKTeX 2.9/fonts/sfd/inconsolata
./Program Files (x86)/MiKTeX 2.9/fonts/tfm/public/inconsolata
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 
./Program Files (x86)/MiKTeX 2.9/fonts/type1/public/inconsolata
./Program Files (x86)/MiKTeX 2.9/source/inconsolata-src.tar.bz2
./Program Files (x86)/MiKTeX 2.9/tex/latex/inconsolata
./Program Files (x86)/MiKTeX 2.9/tex/latex/inconsolata/inconsolata.sty
./Program Files (x86)/MiKTeX 2.9/tpm/packages/inconsolata.tpm

Which seems to confirm that TeX knows and has the font.

I would appreciate any further assistance.

> I'm posting this so that John Nash's and Jay Kerns' solutions to my problem
> are there in the archives ``for the record''.
> Thanks to all who replied.
> cheers,
> Rolf Turner

Brian S. Diggs, PhD
Senior Research Associate, Department of Surgery
Oregon Health & Science University

More information about the R-help mailing list