[R] merge in data.tables -- "non-visible"

Steve Lianoglou mailinglist.honeypot at gmail.com
Wed Mar 2 06:25:50 CET 2011

Hi Ted,

On Tue, Mar 1, 2011 at 9:45 PM, Ted Rosenbaum <ted.rosenbaum at yale.edu> wrote:
> Hi,
> I am trying to use the merge command in the data.tables package.
> However, when I run the command I am not sure if it is running the merge
> command from the base package or the merge command from data.tables.
> When I run "methods(generic.function="merge")' it informs me that
> 'merge.data.table" is "non-visible".
> I am just trying to run the merge command on two data tables using the
> index, is there anything else that I need to do (my googling has simply left
> me uncertain about how to get this to work).
> Thanks for your help!

Assuming everything is "normal", I'm going to bet the merge.data.table
function is the one that is being used.

Assuming you are using version <= 1.5.3, though, an easy way to check
is to see if the result of the merge ignores the `suffixes` argument.
The behavior of merge is being changed for the next version, but this
"feature" is an easy way for you to check which merge function is
being used in the current version ;-)

Hope that helps,

Steve Lianoglou
Graduate Student: Computational Systems Biology
 | Memorial Sloan-Kettering Cancer Center
 | Weill Medical College of Cornell University
Contact Info: http://cbio.mskcc.org/~lianos/contact

More information about the R-help mailing list