[R] Trouble with installing Rmpi package

Tena Sakai tsakai at gallo.ucsf.edu
Sat Jan 8 04:57:36 CET 2011


I made a bit of progress.  I went to open-mpi.org and downloaded
mpi software and installed it, which went smoothly.  Then I re-
 > install.packages( 'Rmpi' )
which worked, except this time it complained about rsprng.  I went
to sprng.cs.fsu.edu and downloaded sprng4 and tried installing it.
went fine, but make failed.  Here's the the failure:

mpif77 -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include   -I../../include
-DSPRNG_MPI -g -O2 -c -o sprngf_simple_mpi_tmp-sprngf-simple_mpi.o `test -f
'sprngf-simple_mpi.F' || echo './'`sprngf-simple_mpi.F
mpif77  -g -O2   -o sprngf-simple_mpi.tmp --showme:link -I/usr/local/include
-pthread sprngf_simple_mpi_tmp-sprngf-simple_mpi.o -L../../lib -lsprng -lm
-lstdc++ -lm
-g -O2 -o sprngf-simple_mpi.tmp -I/usr/local/include -pthread
sprngf_simple_mpi_tmp-sprngf-simple_mpi.o -L../../lib -lsprng -lm -lstdc++
-lm -pthread -L/usr/local/lib -lmpi_f77 -lmpi -lopen-rte -lopen-pal -ldl
-Wl,--export-dynamic -lnsl -lutil -lm -ldl
mv: cannot stat `sprng-simple_mpi.tmp': No such file or directory
make[4]: *** [sprng_mpi_test] Error 1

I issued:
 > library( 'Rmpi' )
which didn't complain.  I don't want to ignore the failure of rsprng package
install, however.

Can somebody please assist me as to how I can get sprng4 installed?

Thank you.

Tena Sakai
tsakai at gallo.ucsf.edu

On 1/7/11 3:49 PM, "Tena Sakai" <tsakai at gallo.ucsf.edu> wrote:

> Hi,
> I am having a problem with installing Rmpi package on redhat linux machine.
> The R I am using is version 2.10.1.  Here¹s what happens.
>> install.packages( 'Rmpi' )
>   --- Please select a CRAN mirror for use in this session ---
>   Loading Tcl/Tk interface ... done
>   trying URL 'http://cran.cnr.Berkeley.edu/src/contrib/Rmpi_0.5-9.tar.gz'
>   Content type 'application/x-gzip' length 87953 bytes (85 Kb)
>   opened URL
>   ==================================================
>   downloaded 85 Kb
>   * installing *source* package âRmpiâ ...
>   checking for gcc... gcc -std=gnu99
>   checking for C compiler default output file name... a.out
>   checking whether the C compiler works... yes
>   checking whether we are cross compiling... no
>   checking for suffix of executables...
>   checking for suffix of object files... o
>   checking whether we are using the GNU C compiler... yes
>   checking whether gcc -std=gnu99 accepts -g... yes
>   checking for gcc -std=gnu99 option to accept ISO C89... none needed
>   checking how to run the C preprocessor... gcc -std=gnu99 -E
>   checking for grep that handles long lines and -e... /bin/grep
>   checking for egrep... /bin/grep -E
>   checking for ANSI C header files... yes
>   checking for sys/types.h... yes
>   checking for sys/stat.h... yes
>   checking for stdlib.h... yes
>   checking for string.h... yes
>   checking for memory.h... yes
>   checking for strings.h... yes
>   checking for inttypes.h... yes
>   checking for stdint.h... yes
>   checking for unistd.h... yes
>   checking mpi.h usability... no
>   checking mpi.h presence... no
>   checking for mpi.h... no
>   configure: error: "Cannot find mpi.h header file"
>   ERROR: configuration failed for package âRmpiâ
>   * removing â/usr/local/lib64/R/library/Rmpiâ
>   The downloaded packages are in
>           â/tmp/Rtmp1J1kDj/downloaded_packagesâ
>   Updating HTML index of packages in '.Library'
>   Warning message:
>   In install.packages("Rmpi") :
>     installation of package 'Rmpi' had non-zero exit status
>> library ('Rmpi' )
>   Error in library("Rmpi") : there is no package called 'Rmpi'
> I think it is upset because the file mpi.h is missing.  Am I right?  If so,
> How would I cure this problem?  And if not, what must I do?
> Please help.  Thank you.
> Tena Sakai
> tsakai at gallo.ucsf.edu
> [[alternative HTML version deleted]]

More information about the R-help mailing list