[R] Problem installing XML in Ubuntu 10.10

Rolf Turner rolf.turner at xtra.co.nz
Tue Apr 26 01:19:07 CEST 2011

On 26/04/11 10:46, Dirk Eddelbuettel wrote:
> On 25 April 2011 at 17:39, Abraham Mathew wrote:
> | Hello folks,
> |
> |
> | Here's is info on what system I'm working on.
> |>  sessionInfo()
> | R version 2.13.0 (2011-04-13)
> | Platform: i686-pc-linux-gnu (32-bit)
> |
> |
> | I'm trying to install the XML package. However, I end up with the following
> | error message.
> You can install the prebuilt package
>      r-cran-xml
> directly from the Ubuntu repositories.

Just out of idle curiosity I tried this.  (Don't want/need XML, but since
I've fairly recently started using Ubuntu, I like to see whether I can drive
these sudo apt-get tools .....)

So I did

     sudo apt-get install r-cran-xml

and it seemed to run without error.  Then I started R and tried


and got the error

     Error in library(XML) : there is no package called 'XML'

So I then said ``Hmmmm.  Maybe I've misunderstood, and the sudo apt-get 
has just provided the underlying xml2-config stuff, and I still need to 
do the install
of the R package XML.  So I tried that, and got the message:

     checking for xml2-config... no
     Cannot find xml2-config
     ERROR: configuration failed for package ‘XML’
     * removing ‘/home/rolf/Rlib/XML’

So either something's not working properly or I'm still not 
understanding what
I should be doing.  Enlightenment?


         Rolf Turner

P. S. I *believe* that I have the Ubuntu repositories referenced 
correctly in
my /etc/apt/sources.list file:

deb http://cran.stat.auckland.ac.nz/bin/linux/ubuntu lucid/

         R. T.

More information about the R-help mailing list