[R] problems installing R (Matteo)

Phil Spector spector at stat.berkeley.edu
Tue Oct 5 23:18:51 CEST 2010

If you are refering to the file GRASS_0.3-9.tar.gz which
you may have downloaded from a CRAN archive, then you normally
do not need to decompress and untar it.  Type

R CMD INSTALL GRASS_0.3-9.tar.gz

at the command line (with the working directory set to where
you've downloaded the file.)

Even better, from inside R, type


to install the package.
 					- Phil Spector
 					 Statistical Computing Facility
 					 Department of Statistics
 					 UC Berkeley
 					 spector at stat.berkeley.edu

On Tue, 5 Oct 2010, ciccpaol at libero.it wrote:

> Hi everybody,
> I'm quite new to ubuntu and tar.gz packages, anyway following these
> instructions https://help.ubuntu.com/community/CompilingEasyHowTo I tried to
> install the R Grass package.
> Everything worked nice until I did:
> $  ./configure
> checking for gcc... gcc -std=gnu99
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc -std=gnu99 accepts -g... yes
> checking for gcc -std=gnu99 option to accept ANSI C... none needed
> checking how to run the C preprocessor... gcc -std=gnu99 -E
> checking for egrep... grep -E
> checking for ANSI C header files... yes
> checking for sys/types.h... yes
> checking for sys/stat.h... yes
> checking for stdlib.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for strings.h... yes
> checking for inttypes.h... yes
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking rpc/xdr.h usability... yes
> checking rpc/xdr.h presence... yes
> checking for rpc/xdr.h... yes
> checking rpc/types.h usability... yes
> checking rpc/types.h presence... yes
> checking for rpc/types.h... yes
> checking for library containing xdrmem_create... none required
> checking zconf.h usability... yes
> checking zconf.h presence... yes
> checking for zconf.h... yes
> checking zlib.h usability... yes
> checking zlib.h presence... yes
> checking for zlib.h... yes
> checking for library containing deflate... -lz
> configure: creating ./config.status
> config.status: creating src/Makevars
> It seems everything OK but
> $ make
> make: *** No targets specified and no makefile found.  Stop.
> I also entered the directory ..../src and typed make but it doesn't work.
> Do I need to write the command "make" or anything else? And in which directory
> do I need to type this command??
> Thanks for your help!!!
> Matteo
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list