[R] Issues loading rtiff 1.4.1 with R 2.6.2 on Windows

Oderbolz Daniel Daniel.Oderbolz at psi.ch
Fri Oct 1 11:49:00 CEST 2010

Dear R-users,

I successfully installed rtiff on by R installation, but when I tried to
load it, I got:

>local({pkg <- select.list(sort(.packages(all.available = TRUE)))
+ if(nchar(pkg)) library(pkg, character.only=TRUE)})
Error in dyn.load(file, ...) :
unable to load shared library
LoadLibrary failure: Das angegebene Modul wurde nicht gefunden.

When running "nm" from MinGW on C:\Program
Files\R\R-2.6.2\library\rtiff\libs\rtiff.dll, it tells me "no symbols"

So I tried to compile the dll from the sources and did this:

gcc -shared -o rtiff.dll rtiff.c -ltiff -lr -I"C:\Program
Files\GnuWin32\include" -I"C:\Program Files\R\R-2.6.2\include"
-L"C:\Program Files\GnuWin32\lib" -L"C:\MinGW\lib" -L"C:\Program
Files\R\R-2.6.2\modules" -L"C:\Program Files\R\R-2.6.2\bin"

This indeed creates a dll witch exports 614 symbols. Also my dll is
29KB, the original one just 9 Kb...

However, R still throws the same error...

Is the infamous space in the Path to R a problem?

Thanks a lot for any hint on this!

P. S: It seems that the author had issues with compilation (ages ago): 


Daniel Oderbolz
Paul Scherrer Institut
CH-5232 Villigen 

Laboratory of Atmospheric Chemistry, 
Gasphase and Aerosol Chemistry Group

Tel: +41 (0)56 310 2449
Fax:               4525
daniel.oderbolz [AT] psi.ch

More information about the R-help mailing list