[R] snow makeCluster (makeSOCKcluster) not working in R-2.11

Ramon Diaz-Uriarte rdiaz02 at gmail.com
Wed May 12 19:12:17 CEST 2010

Interesting: I run into the same problem (also R-2.11) when using
Windows inside VirtualBox from a Debian host (i.e., I am running a
Debian GNU/Linux box that has VirtualBox, and I have a Windows XP as a
guest inside VirtualBox). But I attributed it to my setup (usage of
VirtualBox) as I was told that my code did run OK in a "true" Windows
machine with R-2.11.

By the way, the problem did not always show up, just most of the time
(about 80% to 90% of the attempts).



On Wed, May 12, 2010 at 5:58 PM, Abhijit Dasgupta <dasgupab at mail.nih.gov> wrote:
> Hello,
> I was using snow to parallel-process some code in R-2.10 (32-bit
> windows. ). The code is as follows:
> require(foreach)
> require(doSNOW)
> cl <- makeCluster(6, type='SOCK')
> registerDoSNOW(cl)
> bl2 <- foreach(i=icount(length(unqmrno))) %dopar% {
> (some code here)
> }
> stopCluster(cl)
> When I run the same code in Windows R-2.11 (either 32-bit or 64-bit), R
> hangs at cl<-makeCluster(6, type='SOCK') and no R processes are spawned.
> I was wondering if others have encountered this problem, and any
> suggestions on solving this would be greatly appreciated.
> --
> Abhijit Dasgupta, PhD
> Statistician | Clinical Sciences Section | NIAMS/NIH
>        [[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

Ramon Diaz-Uriarte
Structural Biology and Biocomputing Programme
Spanish National Cancer Centre (CNIO)
Phone: +34-91-732-8000 ext. 3019
Fax: +-34-91-224-6972

More information about the R-help mailing list