[R] Unable to install Cairo package

Sharpie chuck at sharpsteen.net
Thu Mar 18 17:46:47 CET 2010

Alla Bulashevska wrote:
> Dear R users,
> I'm running R version 2.10.1.
> I tried installing the Cairo package and I got the
> following message:
> * installing *source* package ‘Cairo’ ...
> {snip}
> checking cairo.h usability... no
> checking cairo.h presence... no
> checking for cairo.h... no
> configure: error: Cannot find cairo.h! Please install cairo
> (http://www.cairogra
>                                     phics.org/) and/or set
> CAIRO_CFLAGS/LIBS correspondingly.
> ERROR: configuration failed for package ‘Cairo’
> Any help would be greatly appreciated.
> Alla

The Cairo package for R provides an interface to the Cairo graphics library-
therefore that library must be installed for the package to work.  Configure
scripts are notorious for having cryptic error messages, but this one is
actually very explicit about stating what the problem is.

You need to:

  1. Install Cairo and try installing the package again.

Or, if you have Cairo installed in a non-standard location that the
configure script can't find:

  2. Set "-L/path/to/libcairo" in the CAIRO_CFLAGS option and try installing

In cases when package installation is failing, it is also very important to
tell us what operating system you are using as these issues are often

Hope this helps!


Charlie Sharpsteen
Undergraduate-- Environmental Resources Engineering
Humboldt State University
View this message in context: http://n4.nabble.com/Unable-to-install-Cairo-package-tp1598140p1598264.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list