[R] Read SPSS v 18 .sav file

Larry Hotchkiss larryh at udel.edu
Fri Jun 18 16:26:06 CEST 2010


I repeatedly get an error when trying to read an SPSS v. 18 .sav file into R.

> require(foreign)
Loading required package: foreign
> femaleSPSS.dat <- read.spss("female-04-02-2010.sav")
Warning message:
In read.spss("female-04-02-2010.sav") :
  female-04-02-2010.sav: Unrecognized record type 7, subtype 18 encountered in system file

However, read.spss works for .sav files created in older versions of spss.

I did just reinstall foreign to be sure I have the latest version. Does anyone know of an update that works? 


Larry Hotchkiss

More information about the R-help mailing list