[R] Help with RGL package problem

David A. Johnston dajohnston at ucdavis.edu
Wed Dec 15 19:11:08 CET 2010


I have been experiencing an odd error with the RGL package that I cannot
figure out.  I have searched without luck for fixes to this problem on
Rseek, Google, and the R-help-list.

RGL used to work on my machine about a month ago.  It was a very useful
tool.  The graphics device will not initialize now, and I cannot figure out

When I try to load the package using ...

> library(rgl)

... I get a warning message:

Warning messages:
1: In rgl.init(initValue) : RGL: no suitable visual available
2: In fun(...) : error in rgl_init

I also notice I cannot open a new rgl device:

> open3d()
Error in rgl.open() : rgl.open failed

I am on MacOS 10.6.5.  X11 is installed and is working to my knowledge. 
Does anybody have any suggestions to figure this problem out?  I tried
reinstalling the RGL package (v0.92.794), I tried removing all but the base
R packages, I tried installing from both source and binary, I tried
re-installing R (v2.12.0).  No luck with any of these ideas.  

I'm appending my session info and installed packages:

> sessionInfo()
R version 2.12.0 (2010-10-15)
Platform: x86_64-apple-darwin9.8.0/x86_64 (64-bit)

[1] C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

> rownames(installed.packages())
 [1] "base"      "boot"      "codetools" "datasets"  "grDevices" "graphics" 
 [7] "grid"      "methods"   "rgl"       "splines"   "stats"     "stats4"   
[13] "tcltk"     "tools"     "utils"    

-David Johnston

View this message in context: http://r.789695.n4.nabble.com/Help-with-RGL-package-problem-tp3089560p3089560.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list