[R] Can't load "doSMP" from REvolutionR in regular R2.11.0

Tao Shi shitao at hotmail.com
Thu Apr 29 21:48:40 CEST 2010

Hi David,

Thank you for the reply!  Do you know where I can find the source code for these packages?  I can give it a try.


> From: david at revolution-computing.com
> Date: Thu, 29 Apr 2010 08:59:08 -0700
> Subject: Re: [R] Can't load "doSMP" from REvolutionR in regular R2.11.0
> To: shitao at hotmail.com
> CC: r-help at r-project.org
> We haven't tested doSMP with the mingw compiler (hence why we haven't
> yet submitted it to CRAN). We compiled it under R 2.10 using the same
> Intel compilers we use for REvolution R. It is open source (GPL) so
> you're welcome to try compiling it under mingw yourself, but we can't
> offer support for that configuration.
> # David Smith
> On Wed, Apr 28, 2010 at 5:10 PM, Tao Shi  wrote:
>> I was testing out the "doSMP" package from REvolutionR in my regular R2.11.0 installation and I got the following error message.  Well, one obvious thing is that R2.11.0 was built using "i386-pc-mingw32" which is different from what revoIPC used.  I could just use REvolutionR, but all my R peripherals were set up to work
>>  with the regular R2.11.0.  So, I really want to make this work.  Anyideas?
> --
> David M Smith
> VP of Marketing, REvolution Computing  http://blog.revolution-computing.com
> Tel: +1 (650) 330-0553 x205 (Palo Alto, CA, USA)
> Download REvolution R free:
> www.revolution-computing.com/downloads/revolution-r.php
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.


More information about the R-help mailing list