[R] Building Rblas.dll failing on Windows 7 (64-bit)

Udaya B. Kogalur ubk2101 at columbia.edu
Tue Apr 20 22:02:52 CEST 2010

I'm currently attempting to build R-2.10.1 from the source on Windows
7 (64-bit version).  I've downloaded the latest Rtools (Rtools211.exe)
from the Murdoch-Sutherland site and have done a full install.  I've
also downloaded the HTML Help Workshop, MikTeX, and the InnoSetup

I am not using any 64-bit versions of the tools, such as the
MinGW-w64, or a 64-bit version of TCL as I'm just trying to build the
32-bit version of R first.

The only change necessary in Mkrules was the location of the Inno
Setup directory.

The make process gets a considerable way through before exiting with
the following error:

gcc -std=gnu99 -shared -s -mwindows -o R.dll R.def console.o
dataentry.o dynload.o edit.o editor.o embeddedR.o extra.o opt.o
pager.o preferences.o psignal.o rhome.o rt_complete.o rui.o run.o
shext.o sys-win32.o system.o dos_wglob.o e_pow.o malloc.o
../main/libmain.a ../appl/libappl.a ../nmath/libnmath.a getline/gl.a
../extra/xdr/libxdr.a ../extra/pcre/libpcre.a ../extra/bzip2/libbz2.a
../extra/intl/libintl.a ../extra/trio/libtrio.a ../extra/tzone/libtz.a
../extra/tre/libtre.a ../extra/xz/liblzma.a dllversion.o -L.
-lgfortran -lRblas -L../../bin -lRzlib -lRgraphapp -lRiconv -lcomctl32

cp R.dll ../../bin/

-------- Building ../../../bin/Rblas.dll --------

gcc -std=gnu99 -shared  -o ../../../bin/Rblas.dll blas.o cmplxblas.o
../../gnuwin32/dllversion.o Rblas.def -L../../../bin -lR -lgfortran

cannot find -lR

collect2: ld returned 1 exit status
make[3]: *** [../../../bin/Rblas.dll] Error 1
make[2]: *** [Rblas] Error 2
make[1]: *** [rbuild] Error 2
make: *** [all] Error 2

Thus we see that the prior step of building the R DLL has suceeded,
but it fails on the Rblas DLL.  Interestingly, I did notice that if I
repeat "make all recommended", then it fails on the copy command

cp R.dll ../../bin/

as it tries to overwrite the file created on the proir run.  I think
this is a permission issue.  For some reason the R.dll file is read
only.   I'm wondering whether this is somehow related to the failure
in creating the Rblas.dll file.  Any thoughts would be appreciated.
Thank you.


More information about the R-help mailing list