[R] Problem with RGenoud

Uwe Ligges ligges at statistik.tu-dortmund.de
Sun Apr 18 18:46:27 CEST 2010

Please contact the package maintainer.

Uwe Ligges

On 18.04.2010 11:09, yoda55 wrote:
> I've been using RGenoud for a while and it worked smoothly so far. However I
> came across a strange problem lately (for me at least...).
> It fails after the first individual and I get the following error message
> when I set MemoryMatrix = FALSE :
> Error in genoud(fn, nvars = 8, max = TRUE, pop.size = 10,  :
>    REAL() can only be applied to a 'numeric', not a 'character'
> when I set MemoryMatrix = TRUE, it fails after it runs the total number of
> individuals in the 1st generation:
> Error in population[eval.indx, nvars + 2] = 0 :
>    incorrect number of subscripts on matrix
> It sounds like it struggles to write results to an outside source (not sure
> this is the appropriate language). I ran many RGenoud based optimization
> before based the same set up and I never came across that issue before. I
> checked the fn function and it works OK outside RGenoud.
> I'm using R 2.10.1 with under Windows Vista and RGenoud version 5.6-6
> Any help appreciated
> Thanks

More information about the R-help mailing list