[R] behaviour of xls2sep when running read.xls (package gdata) sinceupgrade of R

Olivier ETERRADOSSI olivier.eterradossi at mines-ales.fr
Wed Apr 7 10:46:01 CEST 2010

Hello eveRybody (and probably special regards to Gabor G....),
I recently upgraded from R-2.9.2-win32 to R-10.1.0-win32, and I'm using 
Windows XP Professional 2002 with service pack 3 on a PC with IntelCore 
Duo CPU@ 3.00 GHz.
Last time I used it (some weeks ago, before upgrading), one of my 
scripts (including the two lines cited below) used to run OK.
When I ran it yesterday evening (after upgrading), I get the following 
> > if 
> (test){file1<-"\\\\computername\\dir1name\\subdir1name\\subdir2name\\subdir3name\\filename.xls"
> nap1<- 
> read.xls(file1,sheet=3,method="tab",perl=perl.path,head=T,row.names=1)}
> Erreur dans xls2sep(xls, sheet, verbose = verbose, ..., method = 
> method,  :
>   Unable to read translated tab file 
> 'C:\DOCUME~1\OLIVIE~1.ETE\LOCALS~1\Temp\RtmpPF2rxf\file6df11649.tab'.
> Erreur dans file.exists(tfn) : argument 'file' incorrect
I tried with other xls files, in other folders and on other physical 
disks, and it was still the same.
I didn't upgrade manually either Excel nor Perl , and I cannot see 
tracks of automatic upgrades.
I had a look at the ChangeLog file in the lib/gdata folder, saw that 
some changes were dealing with xls2sep... but couldn't find some help, 
or at least couldn't understand it...

Can someone help, and please excuse me if the answer is obvious... maybe 
I lack some stronger coffee this morning !
Very best regards to all of you. Olivier

animateur du groupe Sensomines (Institut Carnot M.I.N.E.S)
Pôle "Matériaux Polymères Avancés"
axe "Propriétés Psycho-Sensorielles des Matériaux"
Ecole des Mines d'Alès
Hélioparc, 2 av. P. Angot, F-64053 PAU CEDEX 9
tel std: +33 (0)
tel direct: +33 (0) 
fax: +33 (0)
e-mail : olivier.eterradossi at mines-ales.fr

More information about the R-help mailing list