[R] intervals package dependence on R 2.9.0 [results]

Ross Boylan ross at biostat.ucsf.edu
Sun Oct 25 02:33:26 CEST 2009

On Sat, 2009-10-24 at 18:47 +0200, Uwe Ligges wrote:
> Ross Boylan wrote:
> > I notice that the intervals package indicates a dependence on R >=
> > 2.9.0.  Is there some feature of R 2.9 that intervals depends on, or
> > might it work with R 2.7.1, which I am running?
> Don't know, but you could try - bus don't expect the results are valid. 
> The maintainer probably had a reason to declare it dependend on R >= 2.9.0.
For the record, I edited the DESCRIPTION file to use 2.7, and things
mostly appear to be working.  The one exception is that some of the
latex documentation won't build, apparently because of changes in R's
documentation system.

This not a guarantee from me, much less the package maintainer; it's
just a report after some modest use.

> Good time for you to upgrade to teh R-2.10.0 release candidate and act 
> as a test user before Monday when R-2.10.0 will probably be released.
I'm on Debian Lenny, aka stable, so pulling in more recent Debian
packages is likely to cause fairly extensive, potentially destabilizing,
changes to my system.  I realize I could do a custom build (either from
the Debian package or the original source), but I'm trying to avoid
potentially time-consuming side-projects.


More information about the R-help mailing list