[R] compiling R-2.9.2 or R-2.10.0 on ubuntu 9.04 (powerpc)

cremi laurin.mueller at umit.at
Thu Nov 5 10:13:53 CET 2009


I habe installed ubuntu 9.04 server (powerpc) i want to install an R version
> 2.9.0 to run rmpi.

When i add the repository to my sources.list
deb http://cran.at.r-project.org/bin/linux/ubuntu jaunty/
with
#sudo apt-get install r-base
i get this:
The following packages have unmet dependencies:
  r-base: Depends: r-base-core (>= 2.10.0-1jaunty0) but 2.8.1-1 is to be
installed
          Depends: r-recommended (= 2.10.0-1jaunty0) but it is not going to
be installed
E: Broken packages

There exists no binary of on the r-homepage for powerpc (only for i386 or
amd64)

so I tryied to install from source (R-2.9.2 and R-2.10.0)

#./configure
gives me:
...
checking for history_truncate_file... no
configure: error: --with-readline=yes (default) and headers/libs are not
available

#./configure --with-readline=no
i get this error
checking whether f77 appends extra underscores to external names... yes
checking whether mixed C/Fortran code can be run... configure: WARNING:
cannot run mixed C/Fortran code
configure: error: Maybe check LDFLAGS for paths to Fortran libraries?


i have installed:
libg2-dev
libg2c0
libx11-dev
build-essential
i even install
gnome-desktop-environment

now I don't know what to try next. Hopefully someone can help me.

Regards

-- 
View this message in context: http://old.nabble.com/compiling-R-2.9.2-or-R-2.10.0-on-ubuntu-9.04-%28powerpc%29-tp26208637p26208637.html
Sent from the R help mailing list archive at Nabble.com.



More information about the R-help mailing list