[R] help with SSOAP (can't find working examples)

Duncan Temple Lang duncan at wald.ucdavis.edu
Wed Nov 4 05:05:28 CET 2009


Hi Steffen et al.

 The development version of SSOAP and XMLSchema I have on my machine
does complete the processWSDL() call without errors. I have to finish
off some tests before releasing these. It may take a few days before
I have time to work on this, but hopefully soon.

Thanks for the info.

 D.


Steffen Neumann wrote:
> Hi,
> 
> I can confirm this, just today 
> I tried to write a web service client.
> Affected are both SSOAP-0.5-4 and SSOAP_0.4-6.
> 
> I can't access anonymous CVS atm. to check for recent fixes.
> I am unable to map the error message to any of the items in 
> http://www.omegahat.org/SSOAP/Todo.html , is this already known ?
> 
> Yours,
> Steffen
> 
> library(SSOAP)
> Loading required package: XML
> Loading required package: RCurl
> Loading required package: bitops
>> w = processWSDL("http://www.massbank.jp/api/services/MassBankAPI?wsdl")
> Error: Cannot resolve ns:searchPeakDiff in SchemaCollection
> In addition: Warning messages:
> 1: In function (node)  :
>   skipping import node with no schemaLocation attribute
> 2: In processWSDL("http://www.massbank.jp/api/services/MassBankAPI?wsdl") :
>   Ignoring additional <service><port> ... elements
>> sessionInfo()
> R version 2.8.1 (2008-12-22) 
> x86_64-pc-linux-gnu 
> 
> locale:
> LC_CTYPE=en_US.UTF-8;LC_NUMERIC=C;LC_TIME=en_US.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=C;LC_MESSAGES=en_US.UTF-8;LC_PAPER=en_US.UTF-8;LC_NAME=C;LC_ADDRESS=C;LC_TELEPHONE=C;LC_MEASUREMENT=en_US.UTF-8;LC_IDENTIFICATION=C
> 
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods   base     
> 
> other attached packages:
> [1] SSOAP_0.4-6    RCurl_1.3-0    bitops_1.0-4.1 XML_2.5-3   
> 
> 
> w = processWSDL("http://www.massbank.jp/api/services/MassBankAPI?wsdl")
> Error: Cannot resolve ns:searchPeakDiff in SchemaCollection
> In addition: Warning messages:
> 1: In function (node)  :
>   skipping import node with no schemaLocation attribute
> 2: In processWSDL("http://www.massbank.jp/api/services/MassBankAPI?wsdl") :
>   Ignoring additional <service><port> ... elements
> 
> Enter a frame number, or 0 to exit   
> 
>  1: processWSDL("http://www.massbank.jp/api/services/MassBankAPI?wsdl")
>  2: lapply(tmp, processWSDLBindings, doc, types)
>  3: FUN(X[[1]], ...)
>  4: lapply(els, processWSDLOperation, types, doc, namespaceDefinitions, typeDef
>  5: FUN(X[[1]], ...)
>  6: xmlSApply(msg, function(x) {
>  7: xmlSApply.XMLNode(msg, function(x) {
>  8: sapply(xmlChildren(X), FUN, ...)
>  9: lapply(X, FUN, ...)
> 10: FUN(X[[1]], ...)
> 11: resolve(el, typeDefinitions)
> 12: resolve(el, typeDefinitions)
> 13: resolveError("Cannot resolve ", obj, " in ", class(context))
> 
> 
> 
>



More information about the R-help mailing list