[R] ggobi install

Michael Bibo michael_bibo at health.qld.gov.au
Fri Feb 13 00:41:06 CET 2009


Mark Ungrin <mark.ungrin <at> utoronto.ca> writes:

> > * Installing *source* package 'RGtk2' ...
> > checking for pkg-config... /usr/bin/pkg-config
> > checking pkg-config is at least version 0.9.0... yes
> > checking for LIBGLADE... no
> > configure: WARNING: libglade not found
> > checking for INTROSPECTION... no
> > checking for GTK... no
> > configure: error: GTK version 2.8.0 required
> > ERROR: configuration failed for package 'RGtk2'
> > ** Removing '/home/mark/R/i486-pc-linux-gnu-library/2.6/RGtk2'
> > * Installing *source* package 'rggobi' ...
> > checking for pkg-config... /usr/bin/pkg-config
> > checking pkg-config is at least version 0.9.0... yes
> > checking for GGOBI... configure: error: Package requirements (ggobi >= 
> > 2.1.6) were not met:
> >
> > Package gtk+-2.0 was not found in the pkg-config search path.
> > Perhaps you should add the directory containing `gtk+-2.0.pc'
> > to the PKG_CONFIG_PATH environment variable
> > Package 'gtk+-2.0', required by 'libggobi', not found
> >
> > Consider adjusting the PKG_CONFIG_PATH environment variable if you
> > installed software in a non-standard prefix.
> >
> > Alternatively, you may set the environment variables GGOBI_CFLAGS
> > and GGOBI_LIBS to avoid the need to call pkg-config.
> > See the pkg-config man page for more details.


Mark,

The first thing I would look at is whether there are any "*-dev" packages in
synaptic for the libraries etc that are 'missing'.  These -dev packages contain
the header files and are not necessary for running the application, but are
necessary for installing other apps from source that interact with them.  
This is a surprisingly little-advertised issue with Linux packaging that I found
out about from the R installation manual. 

Michael Bibo



More information about the R-help mailing list