[R] Eror message: not a valid package -- installed < 2.0.0

Ben Bolker bolker at ufl.edu
Thu Feb 12 18:02:22 CET 2009


  ./configure --help  gives a list of configuration options.
  I'm not sure, but it looks like there might be a problem
building bzip libraries -- not sure why.

http://cran.r-project.org/doc/manuals/R-admin.pdf

has Solaris building notes for Solaris, but the only mention
of bzip2 in the manual seems to be under HP-UX ... you've
already put /usr/ccs/bin in your path (as suggested in the
manual) ...

  Anyone else out there have clues?

  Ben


Powers, Randall - BLS wrote:
> You are correct. I am definitely an inexperienced, untrained beginner. I
> will read the info in the link. 
> 
> I did think to put /usr/ccs/bin in the Root path (I am doing this logged
> in as Root).
> 
> When I typed make this time, it actually goes through a long process,
> but ends with these error messages. Any speculation on these?
> 
> Thanks again.
> 
> 
> Error code 255
> make: Fatal error: Command failed for target `libbz2.a'
> Current working directory
> /usr/local/lib/R/library/R-2.8.1/src/extra/bzip2
> *** Error code 1
> The following command caused the error:
> make libbz2.a
> make: Fatal error: Command failed for target `R'
> Current working directory
> /usr/local/lib/R/library/R-2.8.1/src/extra/bzip2
> *** Error code 1
> The following command caused the error:
> list='blas bzip2 pcre zlib  intl'; for d in ${list}; do \
>   (cd ${d} && make R) || exit 1; \
> done
> make: Fatal error: Command failed for target `R'
> Current working directory /usr/local/lib/R/library/R-2.8.1/src/extra
> *** Error code 1
> The following command caused the error:
> for d in scripts include extra appl nmath unix main modules library; do
> \
>   (cd ${d} && make R) || exit 1; \
> done
> make: Fatal error: Command failed for target `R'
> Current working directory /usr/local/lib/R/library/R-2.8.1/src
> *** Error code 1
> The following command caused the error:
> for d in m4 tools doc etc share src tests  po; do \
>   (cd ${d} && make R) || exit 1; \
> done
> make: Fatal error: Command failed for target `R'
> # 
> 
> -----Original Message-----
> From: Ben Bolker [mailto:bolker at ufl.edu] 
> Sent: Thursday, February 12, 2009 11:17 AM
> To: Powers, Randall - BLS
> Cc: r-help at r-project.org
> Subject: Re: [R] Eror message: not a valid package -- installed < 2.0.0
> 
>   From the R directory, after configuring successfully, try
> 
>  /usr/ccs/bin/make
> 
>   Do read the INSTALL manual, as BDR suggested ... that also suggests
> 
> MAKE=/usr/ccs/bin/make
> $MAKE (instead of "make")
> 
> it also sounds like you're inexperienced with building software
> (apologies if not true), so the INSTALL file might be written at too
> high a level. You might skim
> http://developers.sun.com/solaris/articles/build_sw_on_solaris.html
> 
>   good luck
>     Ben
> 
> Powers, Randall - BLS wrote:
>> Thanks, that helps some.
>>
>> When I search for make, it appears in a number of places:
>>
>>  # find / -name make -print
>> /usr/share/lib/make
>> /usr/ccs/bin/make
>> /usr/xpg4/bin/make
>> /usr/local/lib/R/library/R-2.8.1/share/make
>> /usr/local/lib/R/share/make
>> /usr/local/lib/R-2.8.1/share/make
>> /apps/oracle/product/10.2/inventory/make
>> /osmrapps/make
>> /osmrapps/make/make-3.70/make
>> /osmrapps/make/make
>>
>> When I cd to the location you suggested, I get:
>>
>> # pwd
>> /usr/ccs/bin
>> # make check
>> make: not found
>> # ./make
>> make: Fatal error: No arguments to build #
>>
>> Am I doing something wrong?
>>
>> Thanks again!
>>
>> -----Original Message-----
>> From: Powers, Randall - BLS
>> Sent: Thursday, February 12, 2009 10:27 AM
>> To: 'Ben Bolker'; r-help at r-project.org
>> Subject: RE: [R] Eror message: not a valid package -- installed < 
>> 2.0.0
>>
>> I am running 2.6.0 because I can't seem to get 2.8.1 configured 
>> properly.
>>
>> When I do ./configure, it goes through a long list, and ends with
>>
>>  configure: error: --with-iconv=yes (default) and a suitable iconv is 
>> not available
>>
>> When I run make, I get the message below.
>>
>>
>> # make
>> make: not found
>>
>> So does anybody have any help regarding how do get the install to
> work?
>> Otherwise, I am stuck with 2.6.0.
>>
>> Thanks
>>
>> -----Original Message-----
>> From: r-help-bounces at r-project.org 
>> [mailto:r-help-bounces at r-project.org]
>> On Behalf Of Ben Bolker
>> Sent: Wednesday, February 11, 2009 2:49 PM
>> To: r-help at r-project.org
>> Subject: Re: [R] Eror message: not a valid package -- installed < 
>> 2.0.0
>>
>>
>>    Is there any reason you can't just install an up-to-date version of
> 
>> R (R 2.8.1), from cran.us.r-project.org (or your favorite mirror, see
>> www.r-project.org) and see if that fixes the problem?  Installing R on
> 
>> SunOS is not quite the breeze that it is on MacOS, Windows, or Linux, 
>> but it's not that bad ... and you are much more likely to get help 
>> from the list if you make it worth people's while to help you by 
>> either (1) explaining why you are stuck with an old version 
>> [regulatory compliance/mission-critical old R software] or (2) 
>> installing recent R and showing that the problem persists.
>>
>>  Ben Bolker
>>
>>
>> Powers, Randall - BLS wrote:
>>>
>>>> Hello R-help,
>>>>
>>>>
>>>> We are running R version 2.6.0 (2007-10-03). I believe that I got it
> 
>>>> from www.sunfreeware.com. A number of the packages that we attempt 
>>>> to
>>>> download from http://www.r-project.org/  give us the error message 
>>>> below when we attempt to run them.
>>>>
>> --
>> View this message in context:
>> http://www.nabble.com/Eror-message%3A--not-a-valid-package----installe
>> d-
>> %3C-2.0.0-tp21962051p21962788.html
>> Sent from the R help mailing list archive at Nabble.com.
>>
>> ______________________________________________
>> R-help at r-project.org mailing list
>> https://stat.ethz.ch/mailman/listinfo/r-help
>> PLEASE do read the posting guide
>> http://www.R-project.org/posting-guide.html
>> and provide commented, minimal, self-contained, reproducible code.
>>
> 
> 
> --
> Ben Bolker
> Associate professor, Biology Dep't, Univ. of Florida bolker at ufl.edu /
> www.zoology.ufl.edu/bolker GPG key:
> www.zoology.ufl.edu/bolker/benbolker-publickey.asc
> 


-- 
Ben Bolker
Associate professor, Biology Dep't, Univ. of Florida
bolker at ufl.edu / www.zoology.ufl.edu/bolker
GPG key: www.zoology.ufl.edu/bolker/benbolker-publickey.asc

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <https://stat.ethz.ch/pipermail/r-help/attachments/20090212/9b8bcfe4/attachment.bin>


More information about the R-help mailing list