[R] Error with hgu133a2.db

Duncan Murdoch murdoch at stats.uwo.ca
Mon Dec 14 13:02:29 CET 2009


mkna005 mkna005 wrote:
> Hi,
> I'm trying to get this library working under R2.10.0. I downloaded it
> and installed it from zip file. i get the following output.
>
>   
>> library(hgu133a2.db)
>>     
> Error in library(hgu133a2.db) : there is no package called 'hgu133a2.db'
>   
>> utils:::menuInstallLocal()
>>     
> package 'hgu133a2.db' successfully unpacked and MD5 sums checked
>   
>> library(hgu133a2.db)
>>     
> Loading required package: AnnotationDbi
> Loading required package: Biobase
>
> Welcome to Bioconductor
>
>  Vignettes contain introductory material. To view, type
>  'openVignette()'. To cite Bioconductor, see
>  'citation("Biobase")' and for packages 'citation(pkgname)'.
>
> Loading required package: DBI
> Error in fun(...) : could not find function "createAnnObjs.HUMANCHIP_DB"
> In addition: Warning message:
> package 'hgu133a2.db' was built under R version 2.7.0 and help will
> not work correctly
> Please re-install it
> Error : .onLoad failed in 'loadNamespace' for 'hgu133a2.db'
> Error: package/namespace load failed for 'hgu133a2.db'
>
> Whats the problem and how can I fix it?
>   

You tried to install a binary for an obsolete version of R.  Find a 
current build instead, or find the source and build one yourself.

It's likely that if the source is of the same vintage as the file you 
installed that it will need updating.  You might have better luck asking 
on the Bioconductor list.

Duncan Murdoch
> Thanks
>
> Christoph
>
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.
>



More information about the R-help mailing list