[R] R installation on Linux/PPC with tcltk support

Ryan Golhar golharam at umdnj.edu
Tue Aug 11 20:40:56 CEST 2009

Nevermind.  I had both the ppc and ppc64 versions of tcl and tk 
installed.  I removed ppc64 versions and everything works now.  Must 
have been a conflict.

Ryan Golhar wrote:
> I'm trying to install R on an IBM P570 running Redhat Enterprise Linux 
> v4.  When I run ./configure, I see:
> checking for tclConfig.sh... no
> checking for tclConfig.sh in library (sub)directories... 
> /usr/lib64/tclConfig.sh
> checking for tkConfig.sh... no
> checking for tkConfig.sh in library (sub)directories... 
> /usr/lib64/tkConfig.sh
> checking tcl.h usability... yes
> checking tcl.h presence... yes
> checking for tcl.h... yes
> checking tk.h usability... yes
> checking tk.h presence... yes
> checking for tk.h... yes
> checking whether compiling/linking Tcl/Tk code works... no
> I have the tcl and tk rpms installed and the configure script does find 
> them properly.  Why can it not compile/link Tck/Tk code?
> Ryan

More information about the R-help mailing list