[R] data$ID -> I always get a NULL

David Winsemius dwinsemius at comcast.net
Mon Apr 20 03:44:16 CEST 2009


On Apr 19, 2009, at 6:45 PM, Grześ wrote:

>
> I have database write as .csv file.

The external sorage format is not likely to be relevant. What might be  
informative would be to produce the code that reads this file.
>
> When I want to get sth from my database I get NULL, but I know that  
> there is
> sth!
> For example:
>
>> data$ID
> NULL
>> data$kod
> NULL
>
> but command like below is always recognize by R
>> data[2,3]
> [1] '082'

Tell is what happens when you enter:

str(data)
class(data)

Perhaps the third column is not named "ID" or "kod" or the object is  
not a data.frame, but is rather a matrix.

-- 
David Winsemius
>
>
> In my opinion this problem is also connect with my attempt to create  
> a tree.
> I always get errors.
>
>> t.tree0=rpart(ID~.,t.train)
> Error in eval(expr, envir, enclos) : object "ID" not found
>
>> t.tree0=rpart(kod~.,t.train)
> Error in eval(expr, envir, enclos) : object "kod" not found
>
> What I should do to create my simple trees?
> -- 
> View this message in context: http://www.nabble.com/data%24ID--%3E-I-always-get-a-NULL-tp23128214p23128214.html
> Sent from the R help mailing list archive at Nabble.com.
>
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

David Winsemius, MD
Heritage Laboratories
West Hartford, CT



More information about the R-help mailing list