[R] X11 font at size 6 could not be loaded

Prof Brian Ripley ripley at stats.ox.ac.uk
Tue Jan 22 23:16:19 CET 2008

Have you also changed your locale?  F8 defaults to UTF-8 locales, whereas 
people usually set up RHEL3 with an 8-bit locale.  That changes the font 
selection, and you may find that running in en_US works whereas en_US.utf8 
does not.

Note that the font you quote is an 8 point 100dpi font, at 11 pixels not 
points.  What you actually need depends on the dpi of your screen, and if 
that is less than 100 dpi you need the 75dpi fonts.

Another idea is to install the scalable fonts in the urw-fonts package, 
and use something like

foo <- getOption("X11fonts")
foo[1] <- "-urw-nimbus sans l-%s-%s-*-*-%d-*-*-*-*-*-*-*"

to select them.

On Tue, 22 Jan 2008, Wittner, Ben, Ph.D. wrote:

> I recently upgraded my OS to Fedora 8 from Red Hat Enterprise Work 
> Station 3. Before I upgraded certain operations would produce a warning 
> to the effect that a desired font was not available so one had been 
> substituted, which was okay. After the upgrade to Fedora 8, the plotting 
> operation halts midway through and I get the following error message:
> "X11 font at size 6 could not be loaded"
> This is not okay, because plotting does not complete.
> I've also gotten that message regarding size 8.

Showing the actual messages would have been helpful.

> In R, if it do getOption("X11fonts") I get
> [1] "-adobe-helvetica-%s-%s-*-*-%d-*-*-*-*-*-*-*"
> [2] "-adobe-symbol-medium-r-*-*-%d-*-*-*-*-*-*-*"
> If from bash I do xlsfonts, I see that I have fonts that match, but the smallest
> seem to be 11 points:
> -adobe-helvetica-bold-o-normal--11-80-100-100-p-60-iso10646-1
> -adobe-helvetica-bold-o-normal--11-80-100-100-p-60-iso8859-1

Looks like you don't have the 75dpi fonts installed, so try installing 
those (xorg-x11-fonts-75dpi, it seems).

> If I run the same program on my Fedora 8 system but use an X server on a Windows
> PC (Hummingbird X server), I have no problem.

That will have scalable fonts.

> If I can't fix this, this is a disaster for me because some of the most common
> things I do are afflicted by this problem.
> Can anyone help me get adobe-helvetica 6 and 8 point fonts onto my system or
> give any other advice?
> Thanks very much.
> -Ben
> p.s., I also tried in R
> options(X11fonts="-misc-fixed-%s-%s-*-*-%d-*-*-*-*-*-*-*")
> but that resulted in
> Error in X11(display, width, height, pointsize, if (is.null(gamma)) 1 else
> gamma,  :
>  invalid 'fonts' value
> when I tried to plot.

Yes, it does have to length 2.

> p.p.s, here's my version information
> platform       i686-pc-linux-gnu
> arch           i686
> os             linux-gnu
> system         i686, linux-gnu
> status
> major          2
> minor          6.1
> year           2007
> month          11
> day            26
> svn rev        43537
> language       R
> version.string R version 2.6.1 (2007-11-26)

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list