[R] failing to load package in R 2.7.1 patched

Monica Pisica pisicandru at hotmail.com
Fri Aug 1 21:32:34 CEST 2008


yesterday i had the surprise not to be able to load the package "ca" on R 2.7.0 saying that cannot find required package rgl although it was there. So today i've upgraded to 7.2.1. patched and i got the following error:

> local({pkg <- select.list(sort(.packages(all.available = TRUE)))
+ if(nchar(pkg)) library(pkg, character.only=TRUE)})
Loading required package: rgl
Error : cannot allocate vector of size 2.0 Gb
Error: package 'rgl' could not be loaded

I've "up-ed" the memory to max which is 4 Gb for my computer and tried again ... same result. I know how to install packages and load them .... or at least i thought so. Do you know what is wrong??

                     sysname                      release 
                   "Windows"                         "XP" 
                     version                     nodename 
"build 2600, Service Pack 2"             

R version 2.7.1 Patched (2008-07-31 r46185) 

LC_COLLATE=English_United States.1252;LC_CTYPE=English_United States.1252;LC_MONETARY=English_United States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] e1071_1.5-18 class_7.2-42

loaded via a namespace (and not attached):
[1] tools_2.7.1

Thanks for any advice,


[[elided Hotmail spam]]

More information about the R-help mailing list