[R] trouble with installing Biobase package

Martin Morgan mtmorgan at fhcrc.org
Thu Sep 13 02:18:04 CEST 2007

Hi Tena -- Please use the Bioconductor mailing list for Bioconductor

You need to update your development version of R to the prerelease
version (provide the output of sessionInfo() with problem reports).


"Tena Sakai" <tsakai at gallo.ucsf.edu> writes:

> Hi Everybody,
> I am having a problem with loading Biobase package.  I typed
> 2 lines below at R prompt
>  > source ("http://boconductor.org/biocLite.R")
>  > biocLite (lib="/usr/local/lib/R/library")
> which attempted to install a bunch of packages with varying
> degree of success.  Out of 29, 13 failed.  Biobase is one of
> them.  As a matter of fact, when I looked at logs, most other
> failures seemed due to the fact Biobase not being there.  So,
> why is Biobase failing to compile?  Here's the complaint:
>  * Installing *source* package 'Biobase' ...
>  ** libs
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c anyMissing.c -o anyMissing.o
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c envir.c -o envir.o
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c matchpt.c -o matchpt.o
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c Rinit.c -o Rinit.o
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c rowMedians.c -o rowMedians.o
>  gcc -std=gnu99 -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include  -I/usr/local/include    -fpic  -g -O2 -c sublist_extract.c -o sublist_extract.o
>  gcc -std=gnu99 -shared -L/usr/local/lib64 -o Biobase.so anyMissing.o envir.o matchpt.o Rinit.o rowMedians.o sublist_extract.o  
>  ** R
>  ** data
>  ** inst
>  ** preparing package for lazy loading
>  Loading required package: tools
>  Error : could not find function "numeric_version"
>  Error: unable to load R code in package 'Biobase'
>  Execution halted
>  ERROR: lazy loading failed for package 'Biobase'
>  ** Removing '/usr/local/lib/R/library/Biobase'
> It is choking at not finding a function "numeric_version".  Has anybody
> seen this before and have any insight to the solution?  I would appreciate
> a bit of helping hand.
> The platform I am on is Dell 64-bit server, running redhat enterprise
> server.
> Regards,
> Tena Sakai
> tsakai at gallo.ucsf.edu
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

Martin Morgan
Bioconductor / Computational Biology

More information about the R-help mailing list