[R] Calling php web service fails

Duncan Temple Lang duncan at wald.ucdavis.edu
Wed Oct 24 08:00:50 CEST 2007

Hash: SHA1

As much as this is standardized, there is a lot
of variability.  It would be much better if you
reported the output of the failure and also tried
to get more information by using some of the
diagnostic facilities in RCurl and SSOAP (cryptic
as they current are).

So, in the absence of somebody having an example
of talking to a PHP Web service, it would be good
to see the details of the error message.


Rohan7 wrote:
> Hi ,
>    I'm trying to call a php webservice. I tried examples given in pdf - R as
> Web Client and SSOAP manual.
> I'm using RCurl and SSOAP library. I'm facing problem with SSOAP - Error in
> getProtocol(server) : 
>   call to standardGeneric("server") and with RCurl i only see the web
> service page.
>  I want to call a PHP web service and send paramters to web service and
> retrieve results using RCurl/SSOAP.
> Can somebody provide me an example for the same which is working?
> Also can somebody explain how sending parameters string or array can be
> achieved?
> Regards,
> Rohan7
Version: GnuPG v1.4.7 (Darwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the R-help mailing list