[R] R-2.6.0 - packages installation through a proxy - not working

Dirk Eddelbuettel edd at debian.org
Tue Oct 16 18:01:50 CEST 2007

On 16 October 2007 at 16:37, Rainer M Krug wrote:
| Liviu Andronic wrote:
| > On 10/16/07, Rainer M. Krug <Rainer at krugs.de> wrote:
| >> I always change the variables in the terminal window before I start R, i.e.
| >>
| >> export http_proxy=SERVER:3128
| >> export ftp_proxy=SERVER:3128
| >>
| >> and then start R - I did it this morning, and it worked.
| > 
| > I always start up Gentoo with these variables set system wide:
| > 
| > localhost m1_1sem # env | grep -i proxy
| > http_proxy=SERVER:3128
| > ftp_proxy=SERVER:3128
| > rsync_proxy=SERVER:3128
| > https_proxy=SERVER:3128
| > 
| > However, R seems to ignore them. I always had to put the necessary
| > variables in Renviron. I have just tried your method, but it also
| > failed. I double-checked the proxy server name, so I doubt the problem
| > is there.
| > 
| > There must be something else that blocks R from accessing the Internet.
| Sounds like it - sorry, but I can't help further.

One option is to use GNU wget which you can configure and test outside of R.
Once you have it working -- and it should work as it AFAICR supports more
arcane proxy settings than R -- you set 


in your Rprofile and you should be fine for all subsequent file operations.

This worked for me when I wrote and submitted the patch to download.file
which Brian Ripley then applied to the R sources.  Also, this should work on
just about any operating system as wget has been ported to most.

Hth, Dirk

Three out of two people have difficulties with fractions.

More information about the R-help mailing list