[R] problem installing fields package 3.5 on R 1.8.1 on linux

Marc Schwartz marc_schwartz at comcast.net
Sat Oct 6 22:23:39 CEST 2007

On Sat, 2007-10-06 at 14:05 -0600, jpgirard wrote:
> I am returning to using R after a little time away.
> Saw some great new functions in the fields package and decided to upgrade.
> Everything seems to go fine until I tried to actually load the package, when
> I get an error:
> >library(fields)
> Error in parse(file, n, text, prompt) : syntax error on line 227
> And (of course) I am unable to access any of the functions in the fields
> package.
> Below is the full install session.
> thanks for any help!
> Jim
> --------------------------
> [root at durX]# R
> R : Copyright 2003, The R Foundation for Statistical Computing
> Version 1.8.1  (2003-11-21), ISBN 3-900051-00-3

You are almost four years out of date here.

R version 2.6.0 was released this past week. I would strongly urge you
to remove your old R installation completely and install R from scratch,
along with new versions of all the packages you require.

Once you have done that, re-install the fields package. There is almost
certainly a conflict between the latest version of fields and your old
version of R.

If there is a still a problem, post back and/or contact the package


Marc Schwartz

More information about the R-help mailing list