[R] installing R with RPM

Casey,Richard Richard.Casey at ColoState.EDU
Mon Nov 12 19:39:42 CET 2007


We're installing R v.2.6 on HP Proliant 32-bit server and RedHat Enterprise Linux v.4 using the binaries and RPM's in CRAN in /bin/linux/redhat/el4/i386.

I could not find instructions on how to use the RPM's.  I assume you issue:

rpm -i R-2.6.0-3.rh4.i386.rpm
rpm -i libRmath-2.6.0-3.rh4.i386.rpm

Is that all there is to it?

I ask the question because we're having trouble installing Bioconductor v.2.1 in R.  Following the Bioconductor install instructions, the gcc/g++ compilers complain about incompatible R libraries, as in:

/usr/bin/ld: skipping incompatible /usr/lib/R/lib/libR.so when searching for -lR

Just wondering if R is installed correctly for Bioconductor.


More information about the R-help mailing list