[R] RMySQL DBI question

David James daj025 at gmail.com
Fri Jun 1 03:29:44 CEST 2007


It would be helpful to have a small reproducible example.  Do you see
the same error if you run "R --save < whatever.R" from the shell prompt?



On 5/31/07, Waverley <waverley.paloalto at gmail.com> wrote:
> Dear colleague,
> I have two data frame which I tried to use dbWriteTable function with
> append=TRUE to write to the mysql database.
> The problem is that if I am run my R script directly then it is fine.  Both
> data frame got written into the database.  But when I tried to embed the
> script to be called as system("R --save < whatever.R") in my perl script, I
> saw very strange things.
> One of the data frame got written into the database without any problem.
> But the other one refused to go to the database with the following error
> message:
> "Error in mysqlExecStatement ... RS-DBI driver: (could not run statement:
> Table ... already exists)
> I have checked on line and find
> http://tolstoy.newcastle.edu.au/R/help/01c/0652.html talks about the same
> problem I have en counted.  But the problem is that I have two data frame,
> one works and the other does not. Also if I don't run under perl and run
> directly R under shell, both works.
> Can someone help?
> I am running R-2.5.0 with RMySQL-0.5-11 and DBI0.2.3.
> I am using linux redhat ES4.0 64 bit.
> --
> Waverley @ Palo Alto
>         [[alternative HTML version deleted]]
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list