[R] Updating packages in Ubuntu feisty for 2.5

Christophe Bonenfant bonenfan at biomserv.univ-lyon1.fr
Wed Jul 25 21:57:18 CEST 2007

Hi -  I do have exactly the same problem with the same distribution 
(Ubuntu Feisty amd64) and am unable to upgrade to R 2.5.1. The 
r-base-core is version 2.4.1 in Ubuntu depositories while all others 
r-cran related packages are upgraded to R 2.5.1 (r-base-dev, r-base...). 
So far I have been unsuccessful at upgrading R. I posted on the Ubuntu 
forum but got no answer yet.


$ uname -a

Linux bronski 2.6.20-16-generic #2 SMP Thu Jun 7 19:00:28 UTC 2007 
x86_64 GNU/Linux

 > R.version
platform       x86_64-pc-linux-gnu
arch           x86_64
os             linux-gnu
system         x86_64, linux-gnu
major          2
minor          4.1
year           2006
month          12
day            18
svn rev        40228
language       R
version.string R version 2.4.1 (2006-12-18)


Colleen Doherty a écrit :
> Hi,
> I would like to run R2.5.1 in Ubuntu feisty on an AMD64 chip.
> I am a total newbie to Linux.
> I have successfully compiled 2.5 however, I am not able to figure out
> how to upgrade the packages.
> I am not able to find an R-base-core_2.5.1-1_amd64 or all on the CRAN mirrors.
> I can find one on the Ubuntu feisty site, however when I try to
> install it I get a warning that Dependency is not stisfiable: libc6
> I am pretty convinced I have libc6 installed.
> When I reinstall it with apt-get It says the latest version is
> currently installed.
> I would appreciate any help or advice that y'all have.
> If this is more appropriate on another list, please let me know where
> and I will post it there.
> Thanks!

More information about the R-help mailing list